In this post, we will see how to resolve Why do my builds fail after installing a pod? Question: I installed a pod (which went fine) but when I try building my .xcworkspace it would fail, regardless of whether I ...

In this post, we will see how to resolve Xcode keeps throwing that i should disable bitcode even though i already disabled it Question: I’m working on react native project and i already deployed android to store without any problem ...

In this post, we will see how to resolve Is it possible to push public CocoaPod that has private CocoaPod dependency? Question: I’m trying to “pod trunk push MyPublicCocoaPod.podspec” to https://github.com/CocoaPods/Specs.git which has dependency of “s.dependency ‘MyPrivateCocoaPod'” (requires below url ...

Question: After I execute a pod install at the base of my project, I get the following error: CocoaPods did not set the base configuration of your project because because your project already has a custom config set. In order ...

Question: I’ve been doing iOS development for a couple of months now and just learned of the promising CocoaPods library for dependency management. I tried it out on a personal project: added a dependency to Kiwi to my Podfile, ran ...

Question: How can I downgrade Cocoapods to an older version, or how can I install an older version of Cocoapods? Best Answer: to remove your current version you could just run: you can install a specific version of cocoa pods ...

Question: I use quite a lot third party libraries which have many warnings in it, after the latest Xcode updates. (for example the Facebook SDK pod) Now all these warnings are shown in my Xcode on the place I want ...

Question: What’s the right way of removing CocoaPods from a project? I want to remove the whole CocoaPod. Due to some limitations imposed by my client I can’t use it. I need to have just one xcodeproj instead of an ...

Question: I have a Flutter app that runs fine on Android devices. It has a Firebase Firestore backend. Now, I want to build it on an iOS simulator, and so I need to initialize the Firebase iOS app. (I had ...

Question: I am trying to do pod install but it says error like: No podspec found for RNFBAnalytics in ../node_modules/@react-native-firebase/analytics I found a solution that says yarn add @react-native-firebase/analytics && cd ios && pod install --repo-update and it eliminates above ...